Double espresso · 355°CcriticalOrder up · fix available
Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
org.apache.tomcat:tomcat-coyote (maven), org.apache.tomcat.embed:tomcat-embed-core (maven)
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.
org.apache.tomcat:tomcat-coyote maven
- On 9.x?
mvn versions:use-dep-version -Dincludes=org.apache.tomcat:tomcat-coyote -DdepVersion=9.0.121 -DforceVersion=true - On 10.x?
mvn versions:use-dep-version -Dincludes=org.apache.tomcat:tomcat-coyote -DdepVersion=10.1.59 -DforceVersion=true - On 11.x?
mvn versions:use-dep-version -Dincludes=org.apache.tomcat:tomcat-coyote -DdepVersion=11.0.25 -DforceVersion=true
org.apache.tomcat.embed:tomcat-embed-core maven
- On 9.x?
mvn versions:use-dep-version -Dincludes=org.apache.tomcat.embed:tomcat-embed-core -DdepVersion=9.0.121 -DforceVersion=true - On 10.x?
mvn versions:use-dep-version -Dincludes=org.apache.tomcat.embed:tomcat-embed-core -DdepVersion=10.1.59 -DforceVersion=true - On 11.x?
mvn versions:use-dep-version -Dincludes=org.apache.tomcat.embed:tomcat-embed-core -DdepVersion=11.0.25 -DforceVersion=true
- First seen
- Last update
- Fixed in
- org.apache.tomcat:tomcat-coyote 11.0.25
- org.apache.tomcat:tomcat-coyote 10.1.59
- org.apache.tomcat:tomcat-coyote 9.0.121
- org.apache.tomcat.embed:tomcat-embed-core 11.0.25
- org.apache.tomcat.embed:tomcat-embed-core 10.1.59
- org.apache.tomcat.embed:tomcat-embed-core 9.0.121
- Identifiers
- Source
- GitHub advisory
- On the menu as
Sources
Wrong fix version, or a source we missed? Send it back to chef@pwned.coffee with the source, and we'll correct it here.
Totalone very hot coffee