pwned.coffeeOrder ticket · today's special · 31 Oct 2026
Double espresso · 355°CcriticalOrder up · fix available
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10,…
Canonical LXD
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
Do this now
Upgrade LXD to 6.10.1, 5.21.9, 5.0.11 or 4.0.15, matching your release line.
Fix it
LXD
- On 4.0.xUpgrade to LXD 4.0.15
- On 5.0.xUpgrade to LXD 5.0.11
- On 5.21.xUpgrade to LXD 5.21.9
- On 6.10.xUpgrade to LXD 6.10.1
- First seen
- Last update
- Fixed in
- 6.10.1
- 5.21.9
- 5.0.11
- 4.0.15
- Identifiers
- CVSS
- 10.0
- Source
- news
Timeline
Fix status: unknown → patched.
First reported.
Receipt
- Exploitation
- No known exploitation
- Fix by release line
Product Affected Fixed in Source LXD before 6.10.1 6.10.1 CVE record (CNA) checked LXD 5.21.8 to before 5.21.9 5.21.9 CVE record (CNA) checked LXD 5.0.10 to before 5.0.11 5.0.11 CVE record (CNA) checked LXD 4.0.14 to before 4.0.15 4.0.15 CVE record (CNA) checked - Score
- CVSS 10.0 (critical). CVSS 4.0 10 (CNA canonical) for CVE-2026-112816
- Last checked
Sources: KEV – CVE record ✓ Vendor ✓
Sources
Wrong fix version, or a source we missed? Send it back to chef@pwned.coffee with the source, and we'll correct it here.
Totalone very hot coffee