pwned.coffeeOrder ticket · past order · 26 Oct 2026
Americano · 183°ChighOrder up · fix available
NGINX Plus: memory corruption
NGINX Plus
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when the rewrite directive is followed by a rewrite, if, or set directive and an unnamed Perl-Compatible Regular Expression (PCRE) capture (for example, $1, $2) with a replacement string that includes a question mark (?).
Fix it
NGINX Plus
- On 37.xUpgrade to NGINX Plus R37
- On 36.xNo fix on 36.x yet
- On 32.xNo fix on 32.x yet
NGINX Open Source
- On 1.30.xUpgrade to NGINX Open Source 1.30.1
- On 1.31.xUpgrade to NGINX Open Source 1.31.0
- First seen
- Last update
- Fixed in
- NGINX Plus R37
- NGINX Open Source 1.31.0
- NGINX Open Source 1.30.1
- Identifiers
- CVSS
- 8.1
- Source
- news
- On the menu as
Timeline
Fix status: unknown → patched.
First reported.
Receipt
- Exploitation
- No known exploitation
- Fix by release line
Product Affected Fixed in Source NGINX Plus before R37 R37 CVE record (CNA) checked NGINX Plus R36 to now no fix on 36.x yet CVE record (CNA) checked NGINX Plus R32 to now no fix on 32.x yet CVE record (CNA) checked NGINX Open Source before 1.31.0 1.31.0 CVE record (CNA) checked NGINX Open Source before 1.30.1 1.30.1 CVE record (CNA) checked - Score
- CVSS 8.1 (high). CVSS 3.1 8.1 (CNA f5) for CVE-2026-42945
- Last checked
Sources: KEV – CVE record ✓ Vendor ✓
Sources
Totalone hot coffee