Double espresso · 355°CcriticalOn hold · status unknown
PHP: remote code execution
PHP
The Gravity Forms plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.1.2 via a Post Custom Field whose input type is List. This is due to GFFormsModel::create_post() passing the submitted value to WordPress' unrestricted global maybe_unserialize() rather than the plugin's own hardened…
Check the Gravity Forms vendor advisory for a fix and restrict access to affected forms meanwhile.
Still cooking for Gravity Forms.
- First seen
- Last update
- Identifiers
- CVSS
- 9.8
- Source
- news
- On the menu as
Receipt
- Exploitation
- No known exploitation
- Fix by release line
Product Affected Fixed in Source Gravity Forms <= 3.1.2 fix not named in the CVE record: see vendor advisory CVE record (CNA) checked The CVE record names no fix for one line; the vendor’s advisory may: docs.gravityforms.com
- Score
- CVSS 9.8 (critical). CVSS 3.1 9.8 (CNA Wordfence) for CVE-2026-103039
- Last checked
Sources: KEV – CVE record ✓ Vendor ✓
Sources
Wrong fix version, or a source we missed? Send it back to chef@pwned.coffee with the source, and we'll correct it here.
Totalone very hot coffee